• Open Source Computer Vision Library

BCB中使用OpenCV

Wikipedia,自由的百科全书

(修订版本间差异)
15:46 2009年1月6日的修订版本
Jdwxy (Talk | 贡献)
安装和配置C++ Builder 6
← Previous diff
21:45 2009年1月6日的修订版本
Ollydbg23 (Talk | 贡献)
把原来链接的两个图片传到wiki里面了。
Next diff →
第 7行: 第 7行:
菜单Tools->Environment Options打开对话框,选择Library标签页(如下图):先设置lib路径,点击Library path后面的…,在弹出窗口中再点…,选择一个路径后,点击Add按钮,加入路径:C:\Program Files\OpenCV\lib。 菜单Tools->Environment Options打开对话框,选择Library标签页(如下图):先设置lib路径,点击Library path后面的…,在弹出窗口中再点…,选择一个路径后,点击Add按钮,加入路径:C:\Program Files\OpenCV\lib。
-[[http://www.opencv.org.cn/forum/download/file.php?id=334]]+[[Image:Open bcb2.JPG]]
- +
-http://www.opencv.org.cn/forum/download/file.php?id=334+
- +
二、项目设置 二、项目设置
第 26行: 第 23行:
(路径:C:\Program Files\OpenCV\lib加到这个地方估计也可以) (路径:C:\Program Files\OpenCV\lib加到这个地方估计也可以)
-[[http://www.opencv.org.cn/forum/download/file.php?id=336]]+[[Image:Open bcb2.JPG]]
-http://www.opencv.org.cn/forum/download/file.php?id=336+

21:45 2009年1月6日的修订版本

安装和配置C++ Builder 6

(CB2009与此类似)

一、全局设置

首先选择File->Close All,关闭所有文档。 菜单Tools->Environment Options打开对话框,选择Library标签页(如下图):先设置lib路径,点击Library path后面的…,在弹出窗口中再点…,选择一个路径后,点击Add按钮,加入路径:C:\Program Files\OpenCV\lib。

Image:Open bcb2.JPG

二、项目设置

File->New->Application新建一个工程,保存至新文件夹。 Project->Options,打开下面的窗口,选择图示标签页:Directory/conditions,点击include path后面的…,弹出对话框,再点…,选择路径后添加。 在下方填入路径: C:\Program Files\OpenCV\cxcore\include C:\Program Files\OpenCV\cv\include C:\Program Files\OpenCV\cvaux\include C:\Program Files\OpenCV\ml\include C:\Program Files\OpenCV\otherlibs\highgui C:\Program Files\OpenCV\otherlibs\cvcam\include

(路径:C:\Program Files\OpenCV\lib加到这个地方估计也可以)

Image:Open bcb2.JPG


三、注意事项

每创建一个将要使用OpenCV的CB Project,都需要将下面的lib拷贝到工程目录下: cxcore.lib cv.lib ml.lib cvaux.lib highgui.lib cvcam.lib

这些文件需要用coff2OMF.exe(?)文件做格式转换。 如果你不需要这么多lib,你可以只添加你需要的lib。

实例代码

参考网页和链接

影像處理簡易程式入門

Views
Personal tools